Unable to connect to Datomic system through the bastion

Until yesterday evening, everything was working perfect. Suddenly from this morning, I am getting this error, when running the bastion command…

$> bash datomic-socks-proxy
fatal error: SSL validation failed for https://-storagef7f305e7-19lxfci-s3datomic-n8csrethjw9w.s3.us-west-2.amazonaws.com//datomic/access/private-keys/bastion [SSL: UNKNOWN_PROTOCOL] unknown protocol (_ssl.c:1076)
Unable to read bastion key, make sure your AWS creds are correct.

Since then, I have created a new EC2 Key Pair, upgraded to the latest (storage & Solo), created new user credentials, and stored as part of the AWS credentials etc. Still showing the same error. What could be the issue? Thanks for the responses.

When I use the datomic client access command, I get the following error.

$>bash datomic client access
Execution error (ExceptionInfo) at datomic.tools.ops.aws/invoke! (aws.clj:83).
AWS Error: Unrecognized SSL message, plaintext connection?

Varified the AWS credentials & SSH setup.

If you’ve upgraded to the latest, you’ll want to do two things:

Some recent changes to the access gateway script and the access gateway are incompatible with prior versions, so you’ll need to make sure you’re using the latest of both.

Thank you for the quick response…

I have downloaded the latest version of the Datomic CLI tools. And it worked, this time!

Thanks again.