Bastion socks working but getting :cognitect.anomalies/not-found


#1

Posting this here just in case others run into it. Perhaps this could also be added to the troubleshooting docs.

I had created an AWS instance of Datomic Cloud and run the socks connection to Bastion. I’d also verified that the socks connection worked by running the curl command specified in the documentation on this page.

However, when I tried to connect I got an error :cognitect.anomalies/not-found.... The problem turned out to be that I had an error in my connection config. I’d omitted the :proxy-port setting. Took me a while to figure it out because the error didn’t give much detail.

Perhaps the troubleshooting docs could also give some advice – if any is to be had – for debugging AWS failures like this. Are there ways (logs, .e.g) of getting a bit more information about what may be wrong?


#2

I had the same problem, but because I was guessing the proxy used port 22. Would be helpful it the docs just showed the default of 8182.


#3

Thanks for the suggestion.
I will look into adding this specific failure mode to the troubleshooting page of the docs.