Bastion refuses connection after failed deployment

After a failed deployment, my Datomic system started refusing connection.

curl: (7) Failed to receive SOCKS5 connect request ack.

The deployment status said FAILED, and that above error is reported to usually be due to credential / security issues (ref: Bastion Fails on Curl Test). So I rechecked all steps, etc. but since I was unsure of how else get more visibility into error so I tried recreating system.

Then it started working again. But after redeploy same error occurred.

Turns out I was pushing an invalid deploy (hence the failure) but I had assumed Datomic would guard for that and rollback? There’s not really any steps in documentation afaik on how to recover from this. (Likely related to this other post: Rollback after failed deploy)

Anyway, after fixing the deploy I was able to connect again. But I’d be useful to have a more informative connection failure message, i.e., can't connect. - invalid deploy.

Figured I’d follow up with a post so that issue is logged for others.

If you have any advice or info about this I’d still appreciate hearing it, thanks!