Datomic Cloud Solo subscription/install failing


#1

I have been trying to create a Solo stack, getting the following error while it is creating the Compute stack. And rolling back the installation.

I have successfully created it a while back…and deleted the instance at that time.

|16:59:41 UTC-0700|CREATE_FAILED|AWS::CloudFormation::Stack|Compute|Embedded stack arn:aws:cloudformation:us-east-1:554409359773:stack/iw-dc-stack-dev-Compute-2Z4IDT94JOPZ/fa11ab20-d19e-11e8-ae45-50fae98a24fd was not successfully created: The following resource(s) failed to create: [TxLaunchConfig].

||Physical ID: arn:aws:cloudformation:us-east-1:554409359773:stack/iw-dc-stack-dev-Compute-2Z4IDT94JOPZ/fa11ab20-d19e-11e8-ae45-50fae98a24fd

||Client Request Token: Console-CreateStack-6562ff93-ba1a-49bf-9aa5-edf9dc9d5c2a|


#2

I tried again, after 3 hours. And this time it just worked!! Didn’t do anything different from the last few tries when it failed with the above message.

Thanks.


#3

if I do not have 3 hours, how should I proceed?


#4

I think it takes some time to clear all the instances/storages to be deleted by the AWS. Don’t know exactly how much time it took. Only thing I know is I retried only after 3 hours!!

Or create instances with different names…


#5

If you are launching a system using the “master” template hosted by AWS Marketplace (instead of Storage and Compute stacks separately, see: Upgrading), finding the causal error for failed CloudFormation templates can require a bit of spelunking.
You may need to switch the view in the CFT dashboard to see “failed” or “deleted” stacks:

Then select the failed stack(s) and look in the ‘Events’ tab to determine the reason they failed.

Often, if you’re re-using previous names, they will have failed because they tried to create a resource that already exists. You can find details on deleting your stack cleanly here:

https://docs.datomic.com/cloud/operation/deleting.html#deleting-storage

You may also need to search for resources that can’t be automatically cleaned up by using tag search:

https://docs.datomic.com/cloud/operation/monitoring.html#tags