Cast logs not appearing in CloudWatch

I’ve followed the instructions here: Monitoring Ions | Datomic

But none of my logs end up in CloudWatch.

I have also followed the instructions in this post to look in the correct location for the logs:

However my own logs are not appearing. I’ve tried with cast/event, cast/dev, java logging but with no luck

Any ideas?

Similar symptom here. I’ve been trying datomic using both production topology and locally using a REPL. When deployed in the cloud, I cannot find the log anywhere in the CloudWatch Log Stream. When run locally, cast/event shows the following error

=> (require '[datomic.ion.cast :as cast])
nil
=> (cast/event {:msg "A" ::event ::foobar})
Execution error (IllegalArgumentException) at datomic.ion.cast.impl/fn$G (impl.clj:14).
No implementation of method: :-event of protocol: #'datomic.ion.cast.impl/Cast found for class: nil

Modern application often use a lifecycle and dependencies management tool such as component and duct. If cast depends on a shared global variable, maybe we should let user manage it?

Hi @hden

You need to initialize-redirect for local workflows. Your REPL is a local workflow. You can then prn all alert,event and dev output to stderr, stdout, for a filename. With clojure 1.10 you can also target a registered tap.

https://docs.datomic.com/cloud/ions/ions-monitoring.html#local-workflow

For @wkok,

Werner and I worked together on a support case and we found that he was using cast/dev which does not post to CloudWatch. Our docs were not clear on this so we added a note to the cast/dev section here: Monitoring Ions | Datomic

NOTE Configuring a destination for cast/dev when running in Datomic Cloud is currently not supported, and dev calls do not post to CloudWatch.