The Entity Vanishes?

I’ve got a schema with a bunch of user information in it. It has entities: User, Organization, things like that, and also a Message entity.

I’ve got a console pointed at the schema and everything looks A-OK. But when I go to the use the code, it acts as if the Message entity no longer exists. No matter what field I try to query on, I get:

“:db.error/not-an-entity Unable to resolve entity :message/attribute”

Setting aside how it happened, I honestly don’t see how this is even possible. Can you retract a schema entity? I thought that wasn’t possible.

Are sure theres is no mistake in attribute ident? letter case is sensitive

Can you show your schema, screenshot from datomic browse console is enough

I am sure.

This is not me typing in a REPL, this is code that worked which then stopped working. I did go into a REPL to fix the problem, which I did by calling a function which transacts the schema—which is also in the code, and not something I was free-typing.


And when I ran the code, it did not know what any of :message/content, :message/receivers, :message/sender or :message/time were.

According to this screenshot you do not have attribute :message/attribute

I should have typed this as :message/[attribute]

I have four fields. Each of those fields was reported as unknown. So:

“:db.error/not-an-entity Unable to resolve entity :message/sender”
“:db.error/not-an-entity Unable to resolve entity :message/content”
“:db.error/not-an-entity Unable to resolve entity :message/time”
“:db.error/not-an-entity Unable to resolve entity :message/receivers”

Is it possible that your code is querying the wrong database by passing a bad parameter, shifting a parameter, or connecting to the wrong database somewhere?

I think that’s the only possibility, right? I mean, the entity is visible in the console but not in the REPL, so I think that suggests that they can’t be looking at the same place. What I don’t get is how it was strictly and only that entity. Unless something set the DB back somehow to before it had that schema. (I mean, it was one of the latest things added, but that was nearly a year ago, and I would think other issues would have arisen if that had happened.)