Cognitect dev-tools version 0.9.72 now available

Version 0.9.72 of Cognitect dev-tools is now available for download.
See Cognitect dev-tools.

2022/04/06 - 0.9.72


2022/04/06 - 1.0.243

  • Upgrade Client to 1.0.126


2022/04/06 - 0.9.245

  • Upgrade Clojure to 1.11.1

Is dev-local 1.0.243 properly deployed to maven central?

We had no issue downloading 1.0.242.

Dev-tools isn’t on maven central or in the datomic-cloud repository.

The e-mail that you received when you requested dev-tools will have a link to maven configuration for dev-tools.

Check to make sure that your ~/.m2/settings.xml has the correct credentials and that your deps.edn has the correct :mvn/repos “cognitect-dev-tools” key and value.

All this setup is already done and worked well until I bumped to 1.0.243.

I think I see what may be causing the issue for some of our users. We’ll work on that this morning.

I’ll let you know soon as we have a fix.

1 Like

I was able to reproduce what I believe your issue was and deploy a fix.

Check and let me know of 1.0.243 is available for you now via maven.

You may need to clear the local .cpcache in the project directory and delete ~/.m2/repository/com/datomic/dev-local/1.0.243. (I had a bad pom get cached when testing the solution, and I suspect it will happen to most users who encountered this problem)

1 Like

Your fix worked, and we didn’t need to clear the .cpcache, thankfully.
That wouldn’t have been fun in the CI-CD context. :slight_smile:

Thanks @Robert-Randolph

I hit this issue too, but rm -rf .cpcache ~/.m2/repository/com/datomic/dev-local/1.0.243/ didn’t seem to help at 1st glance.

It turned out that the problem was that I tried to use the Refresh Clojure Deps Projects Cursive operation, but that somehow just gave me this error:

The following errors were found during project resolve: /Users/XXX/.../deps.edn: status code: 401, reason phrase: Unauthorized (401)

The most likely issue is that IntelliJ doesn’t see the same process environment as my shell, hence it tried to access the Cognitect dev-tools maven repo ( without the correct credentials.

The solution is to just run clojure -A:... from a shell, which should successfully download dev-local version 1.0.243.

Subsequent Refresh Clojure Deps Projects actions won’t try to download it, hence they should succeed.