# Unable to resolve entry point, make sure you have the correct version of com.datomic/client on your classpath

**URL:** <https://forum.datomic.com/t/unable-to-resolve-entry-point-make-sure-you-have-the-correct-version-of-com-datomic-client-on-your-classpath/930>\
**Category:** Troubleshooting\
**Created:** [April 16, 2019, 11:42am UTC](https://forum.datomic.com/t/unable-to-resolve-entry-point-make-sure-you-have-the-correct-version-of-com-datomic-client-on-your-classpath/930 "2019-04-16T11:42:48Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![marco](https://avatars.discourse-cdn.com/v4/letter/m/a698b9/32.png) [@marco](https://forum.datomic.com/u/marco)\
**Post date:** [April 16, 2019, 11:42am UTC](https://forum.datomic.com/t/unable-to-resolve-entry-point-make-sure-you-have-the-correct-version-of-com-datomic-client-on-your-classpath/930/1 "2019-04-16T11:42:48Z")

</div>

I’m trying to connect to a Datomic Cloud instance through Tomcat on AWS running jetty. It was working but something changed and now I am receiving the following error  
`Unable to resolve entry point, make sure you have the correct version of com.datomic/client on your classpath`  
Not sure how to debug this.

---

<div class="post-metadata">

**Author:** ![marshall](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.datomic.com/marshall/32/48_2.png) [@marshall](https://forum.datomic.com/u/marshall)\
**Post date:** [April 30, 2019, 3:10pm UTC](https://forum.datomic.com/t/unable-to-resolve-entry-point-make-sure-you-have-the-correct-version-of-com-datomic-client-on-your-classpath/930/2 "2019-04-30T15:10:18Z")

</div>

Can you provide the client configuration map that you are using for the connection?  
You mention that “something changed” - did you possibly change any AWS networking or permissions/security groups settings?

---

<div class="post-metadata">

**Author:** ![marco](https://avatars.discourse-cdn.com/v4/letter/m/a698b9/32.png) [@marco](https://forum.datomic.com/u/marco)\
**Post date:** [April 30, 2019, 6:03pm UTC](https://forum.datomic.com/t/unable-to-resolve-entry-point-make-sure-you-have-the-correct-version-of-com-datomic-client-on-your-classpath/930/3 "2019-04-30T18:03:53Z")

</div>

Is this what you mean by client configuration:

```
    {
   :server-type :ion
   :region "us-east-1"
   :system "xxxxxxxx"
   :endpoint "http://vpce-xxxxxxxxxxxxxxxxx-xxxxxxx.vpce-svc-xxxxxxxxxxxxxxxxx.us-east-1.vpce.amazonaws.com:8182/"
   }

```

The only thing I did was upload and deploy a new version that fixed a very minor bug, so doubt it was that. Actually every time this occurred was after an upload and deploy. From all my research it always seems to be pointing to a Tomcat issue, but really unsure.

Finally, I resolved the issue by not going with Tomcat, but by just serving the app using Jetty on an ELB running Java, with a Nginx reverse proxy. Now it runs without errors and I can upload and deploy without issue.

Would you like other information? Otherwise thank you so much for your response. It is greatly appreciated. 🙂

---

<div class="post-metadata">

**Author:** ![marshall](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.datomic.com/marshall/32/48_2.png) [@marshall](https://forum.datomic.com/u/marshall)\
**Post date:** [April 30, 2019, 6:49pm UTC](https://forum.datomic.com/t/unable-to-resolve-entry-point-make-sure-you-have-the-correct-version-of-com-datomic-client-on-your-classpath/930/4 "2019-04-30T18:49:40Z")

</div>

I’m glad you were able to resolve the issue.

It does indeed sound like Tomcat may have been the issue since you were able to resolve the problem using Jetty directly.

---

<div class="post-metadata">

**Author:** ![marco](https://avatars.discourse-cdn.com/v4/letter/m/a698b9/32.png) [@marco](https://forum.datomic.com/u/marco)\
**Post date:** [May 1, 2019, 3:29pm UTC](https://forum.datomic.com/t/unable-to-resolve-entry-point-make-sure-you-have-the-correct-version-of-com-datomic-client-on-your-classpath/930/5 "2019-05-01T15:29:31Z")

</div>

I didn’t resolve the issue on Tomcat in AWS, other than what I did, but I managed to reproduce the error, so writing it here in case someone else searches for it.

I managed the reproduce the error when running the application by having a compile JAR (in the target folder) and then compiling and running in debug through the IDE. This seems to create a library resolution issue in Java.

So I’m deducing that when uploading and deploying to Tomcat on AWS, it must have a cache that keeps the old jar at the same time as the new jar, and thus probably creates this resolution issue.
