# Unable to connect to Datomic Cloud using VPC endpoint

**URL:** <https://forum.datomic.com/t/unable-to-connect-to-datomic-cloud-using-vpc-endpoint/1253>\
**Category:** Datomic Cloud\
**Created:** [November 19, 2019, 4:02am UTC](https://forum.datomic.com/t/unable-to-connect-to-datomic-cloud-using-vpc-endpoint/1253 "2019-11-19T04:02:48Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![akurathiph](https://avatars.discourse-cdn.com/v4/letter/a/a5b964/32.png) [@akurathiph](https://forum.datomic.com/u/akurathiph)\
**Post date:** [November 19, 2019, 4:02am UTC](https://forum.datomic.com/t/unable-to-connect-to-datomic-cloud-using-vpc-endpoint/1253/1 "2019-11-19T04:02:48Z")

</div>

Datomic cloud successfully installed on AWS and able to access it using socks proxy. Now we are trying to connect to Datomic using VPC endpoint with REPL commands from a client machine which is outside of the datomic VPC. The VPC endpoint was created by following the steps mentioned in

[https://docs.datomic.com/cloud/operation/client-applications.html#create-endpoint](https://docs.datomic.com/cloud/operation/client-applications.html#create-endpoint)

Here is the error that we are facing.

Execution error (ExceptionInfo) at datomic.client.impl.cloud/get-s3-auth-path (cloud.clj:178).  
Unable to connect to http://:8182

---

<div class="post-metadata">

**Author:** ![akurathiph](https://avatars.discourse-cdn.com/v4/letter/a/a5b964/32.png) [@akurathiph](https://forum.datomic.com/u/akurathiph)\
**Post date:** [November 21, 2019, 4:02am UTC](https://forum.datomic.com/t/unable-to-connect-to-datomic-cloud-using-vpc-endpoint/1253/2 "2019-11-21T04:02:26Z")

</div>

The VPC endpoint security group is allowing traffic only from a particular security group. I updated the security group inbound rules to allow traffic from Client machine and now i am able to access Datomic with VPC endpoint.
