# REPL on the Compute notes?

**URL:** https://forum.datomic.com/t/repl-on-the-compute-notes/837
**Category:** Datomic Cloud
**Created:** [February 13, 2019, 10:33am UTC](https://forum.datomic.com/t/repl-on-the-compute-notes/837 "2019-02-13T10:33:35Z")
**Posts on this page:** 1
**Showing post:** 4

<div class="post-metadata">

### Author: ![eneroth](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.datomic.com/eneroth/32/191_2.png) [@eneroth](https://forum.datomic.com/u/eneroth)
#### Post date: [March 4, 2019, 1:38pm UTC](https://forum.datomic.com/t/repl-on-the-compute-notes/837/4 "2019-03-04T13:38:15Z")

</div>

We had an issue this morning, same symptoms as described over in…

> [@API Gateway internal server error](https://forum.datomic.com/t/api-gateway-internal-server-error/678):
>
> This kind of looks like a cold start issue, since it only happens after I make a request against API gateway routes after not using them for a little while. The first request always returns an internal server error to me. From the associated lambda logs, I see this error: java.io.IOException: Connection reset by peer: datomic.ion.lambda.handler.exceptions.Fault datomic.ion.lambda.handler.exceptions.Fault: java.io.IOException: Connection reset by peer at datomic.ion.lambda.handler$throw\_anomaly…

… except this time it was persistent. I solved it by terminating the node. It returned 500 on requests, but for some reason the NLB was perfectly fine with this and didn’t terminate it automatically.

We’re now looking at more liberal sprinkling of `cast`s throughout the code to catch it next time when/if it happens, but this seems a bit like black box engineering. It would have been nice to have a more direct way to inspect the state of the machine.

---

_[View the full topic](https://forum.datomic.com/t/repl-on-the-compute-notes/837)._
