Datomic console not supported on current version?

i recently started learning datomic, and the experience has been amazing. however when i tried the console, following the on-prem documentation, i got the following error message:

ERROR: This version of Console requires Datomic 0.8.4096.0 to run

i downloaded datomic-pro-1.0.6165 and tried with a starter account. this error message occurs even with just bin/console --help. the required version is quite far behind the current version. i wonder, is the console no longer supported?

1 Like

Hi @Ysmiraak,

May I ask what version of starter you were trying to run? Datomic Pro ships with console included. So you don’t need to use (and more importantly it won’t work with) the standalone console provided for Starter users.

You should be able to execute bin/console from the latest pro distribution root directory.


hi jaret, thanks for the reply! glad to here that this is unexpected behavior.

i downloaded datomic from the link on the account page https://my.datomic.com/repo/com/datomic/datomic-pro/$VERSION/datomic-pro-$VERSION.zip with VERSION=1.0.6165 which was the newest version i found on https://my.datomic.com/downloads/pro.

i assumed that the starter is just pro with a different license? i could not find link specifically for starter, and i did not use the standalone console.

i could use bin/transactor and bin/run just fine. i’ve also use bin/maven-install and bin/repl. only that bin/console did not work for me.

We have confirmed this behavior and will be working on a fix for the next release.


Hi @ysmiraak!

Thank you for reporting this issue. We have released a fix on the stand-alone console. You can download here https://my.datomic.com/downloads/console. You’ll need to follow the README for running the bin/install-console command, supplied with the directory of your Datomic on-prem distribution. Going forward, future releases of Datomic on-prem will include the fixed console version.

Announcement and change log links:



Hi @jaret , I’m arriving here on the same journey. I downloaded the stand-alone console distributable and ran the ./bin/install-console $DATOMIC_HOME script. It printed:

 Installing Datomic Console...
 Copying files...

this is my startup invocation:

bin/console -p 80 datomic datomic:ddb://re-gion-1/something-datomic/

App does not start up, produces no java logs and prints this on stderr

Execution error (FileNotFoundException) at clojure.main/main (main.java:40).
Could not locate datomic/console__init.class, datomic/console.clj or datomic/console.cljc on classpath.

Full report at:

I can’t easily get to that .edn file with the full report.

Are you running bin/console from the Datomic install directory (Should be the same location where you installed console)? The error indicates that it cannot find console on classpath.

I finally got it working. The install-console script did not quite work by itself. My (complete) installation now looks like this:

unzip -q /tmp/files/datomic-$DATOMIC_VERSION.zip -d /opt && \
	unzip -q /tmp/files/datomic-console-$DATOMIC_CONSOLE_VERSION.zip -d /opt && \
	( cd /opt/datomic-console-$DATOMIC_CONSOLE_VERSION && \
	bin/install-console $DATOMIC_HOME && \
	cp -R ./* $DATOMIC_HOME/ )

That last cp -R ./* $DATOMIC_HOME/ from the datomic-console extracted zip folder is what made it work. After this patch I can run bin/console from the datomic installation folder.