# Datomic cloud failure on import-cloud

**URL:** <https://forum.datomic.com/t/datomic-cloud-failure-on-import-cloud/2366>\
**Category:** Datomic Cloud\
**Created:** [January 9, 2024, 4:09pm UTC](https://forum.datomic.com/t/datomic-cloud-failure-on-import-cloud/2366 "2024-01-09T16:09:04Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![itaied](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.datomic.com/itaied/32/598_2.png) [@itaied](https://forum.datomic.com/u/itaied)\
**Post date:** [January 9, 2024, 4:09pm UTC](https://forum.datomic.com/t/datomic-cloud-failure-on-import-cloud/2366/1 "2024-01-09T16:09:04Z")

</div>

hey all  
I’m trying to run `import-cloud` but it fails with the error:

```auto
; Execution error (IllegalArgumentException) at datomic.dev-local.impl/fn (impl.clj:493).
; This client does not support dev-local import.

```

My setup is:  
`deps.edn`

```auto
{com.datomic/client-cloud {:mvn/version "1.0.124"}
 com.datomic/local {:mvn/version "1.0.276"}}

```

`dev.clj`

```auto
(defn sync-local []
  (let [conf (->> (io/resource "dev/config.edn")
                  slurp
                  edn/read-string)]
    (dl/import-cloud
     {:source (merge conf {:db-name "dev-itai"})
      :dest {:system "production-rep"
             :server-type :datomic-local
             :db-name "db-name"
             :storage-dir :mem}})))

```

`config.edn`

```auto
{:server-type :ion
 :region "region"
 :system "system"
 :endpoint "url"}

```

I couldn’t figure out why as I followed the [docs](https://docs.datomic.com/cloud/datomic-local.html#getting-started).  
What am I missing here?

---

<div class="post-metadata">

**Author:** ![jaret](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.datomic.com/jaret/32/45_2.png) [@jaret](https://forum.datomic.com/u/jaret)\
**Post date:** [January 9, 2024, 7:31pm UTC](https://forum.datomic.com/t/datomic-cloud-failure-on-import-cloud/2366/2 "2024-01-09T19:31:18Z")

</div>

@itaied

I think the issue here is `:storage-dir :mem` see:

```auto
(dl/import-cloud
  {:source {:system "tomhanks"
            :db-name "repodb2"
            :server-type :ion
            :region "us-east-1"
            :endpoint "https://awrqwigbi6.execute-api.us-east-1.amazonaws.com"}
   :dest {:system "tomhanks"
          :server-type :datomic-local
          :db-name "repodb2"
          :storage-dir :mem}
   })
Execution error (IllegalArgumentException) at datomic.dev-local.impl/fn (impl.clj:493).
This client does not support dev-local import.
(dl/import-cloud
  {:source {:system "tomhanks"
            :db-name "repodb2"
            :server-type :ion
            :region "us-east-1"
            :endpoint "https://awrqwigbi6.execute-api.us-east-1.amazonaws.com"}
   :dest {:system "tomhanks"
          :server-type :datomic-local
          :db-name "repodb2"}
   })
=> {:from-t 7, :tx-count 0}

```

I am confirming with the team but I do not believe you are able to import a cloud db to a `mem` DB. Our documentation certainly does not tell you that you cannot do this. And either way the error message here is outdated (mentioning dev-local vs datomic local) and unhelpful.

---

<div class="post-metadata">

**Author:** ![itaied](https://sea2.discourse-cdn.com/flex016/user_avatar/forum.datomic.com/itaied/32/598_2.png) [@itaied](https://forum.datomic.com/u/itaied)\
**Post date:** [January 10, 2024, 8:05am UTC](https://forum.datomic.com/t/datomic-cloud-failure-on-import-cloud/2366/3 "2024-01-10T08:05:06Z")

</div>

Thanks @jaret it worked!
